
How to use 3D ART VeSElecT 

It is essential for the functionality of the macro that all steps are followed exactly according to 

this guideline. 

It is recommended to read the whole user description one time before starting to use the 

macros. 

 

The automated registration and characterization of the neuronal vesicles was implemented as two 

macros for Fiji [1]. Fiji is a version of ImageJ [2] which includes a wide range of plugins for biological 

image analysis. The first macro (3DART_VeSElecT_RegistVesicle.ijm) allows the registration of 

vesicles and includes steps for the preprocessing, separation of the foreground, removal of 

interfering components and segmentation of individual vesicles. Afterwards all registered vesicles 

can be characterized with the use of a second macro (3DART_VeSElecT_MeasureVesicle.ijm). This 

separation allowed manual erasure of falsely registered particles from the final characterization. 

Preparations: 

Install Fiji: 

For application of the macros you need the image processing software Fiji [1] and one additional 

plugin (3D ImageJ Suite[4]). 

We successfully tested 3D ART VeSElecT using the latest version 1.51g on different operating 

systems (Linux, Windows and Macintosh). 

If you would like to install Fiji you have two options: 

 Recommended option: You can find a Fiji version for Linux systems on our homepage ready 

for download (already includes 3D ImageJ Suite): 

 Download the zip-file 

 Unzip the package (password: sch4ch) 

 Unzip Fiji.app_1.zip (for linux-systems) 

 Start Fiji by pushing ImageJ-linux64 button 

 DO NOT UPDATE THIS VERSION (ignore pop-up) 

 If Fiji is started the first time some windows may pop up. Just ignore these windows by 

closing them. 



 Second option: You can download Fiji for different systems on this homepage: 

https://fiji.sc/ 

Install 3D ImageJ Suite 

http://imagejdocu.tudor.lu/doku.php?id=plugin:stacks:3d_ij_suite:start 

Disadvantage: if there have been some new updates in one of the plugins used in the 

macro we can’t guarantee the flawless function of the macro. 

 

Download the macros “3DART_VeSElecT_RegistVesicle.ijm” and 

“3DART_VeSElecT_MeasureVesicle.ijm” 

 Use the download link on our homepage (http://yana.bioapps.biozentrum.uni-

wuerzburg.de/computing/3dart_veselect/) to download the macros. 

 The macros are password-protected (password: sch4ch). 

 Unzip the macros to a convenient place on your computer (e.g., the Desktop). 

Prepare your data: 

 Download the test_stack.tif from our homepage (password: sch4ch) 

If you use the test stack you can skip the rest of this chapter and continue at Apply 

“3DART_VeSElecT_RegistVesicle.ijm” 

 If you don’t use the test_stack.tif, but your own electron tomography stack you need to 

convert your “example.rec” stack into an “example.tif” stack. Following you will find a 

description how I converted my .rec stacks into .tif stacks on linux systems, using the 

command line. 

 If you convert your stack in a different way, than described below, you need to regard, 

that the conversion should not influence the original pixel size. Changes in pixel size most 

likely will result in a loss of resolution. Furthermore it is crucial for the application of the 

macros to know the exact pixel size, otherwise the wrong particle size will be found by the 

macro. 

How to create a tiff file from a rec file: 

 

 change directory into the folder with your sum.rec file 

 use the following commands (bold font): 

1) clip flipyz example.rec example2.rec 

(Rotation of stack, name of stack, name of converted stack) 



 

2) mrc2tif -s example2.rec example2.tif 

(convertion of mrc data to tif, name of stack, name of converted stack) 

Apply “3DART_VeSElecT_RegistVesicle.ijm”: 

If you follow this guideline exactly and you still receive an error message, look at the end of this 
instruction. Some messages that may occur and its solutions are explained on the second to last 

page of this guideline. 
 

 Start Fiji 

 Open your own stack or the test stack: File > Open > select test_stack.tif 

 Optional: For reducing long duration of calculation, crop your tomogram (Image > Crop) if 

possible (not necessary for test_stack.tif). 

 Optional: If necessary, remove the first and last pictures of the stack (not necessary for 

test_stack.tif), because pictures of high tilt angles often lack quality, therefore provide no 

relevant information. Furthermore undefined structures will increase the error rate of the 

automated recognition.  

For removal of first and last pictures use: Image > Stacks > Tools > Slice Keeper.  

Hence a window opens, where the number of the first and last slice that you want to keep 

has to be inserted. For number of increment choose 1. 

 Open the macro by using: Plugins > Macros > Edit > open 

“3DART_VeSElecT_RegistVesicle.ijm”. (If you would like to use the “Measurement Makro” 

later you can already open this macro “3DART_VeSElecT_MeasureVesicle.ijm” the same 

way as described above.) 

 

 Now, you have an opened TIF stack in Fiji and a window with the opened macro(s) (see 

Figure 1). 



 

Figure 1: Screenshot shows the Fiji program window, the test_stack.tif tomogram and a window with the macro "3D ART 

VeSElecT” (“RUN” button is highlighted with red box). 

 Select the “3DART_VeSElecT_RegistVesicle.ijm” and press the “RUN” button at the left 

down corner (see Figure 1, red box).  

 A window with 6 parameters will appear. If you use the test stack, you just have to click 

“OK” and continue with the next step Select area of interest. 

 

 Put in the suitable pixel sizes for your tomogram and click “OK” (Figure 2).  

Pixel size for test_stack.tif: 0.574 for x, y and z (default). 

Parameters for sphericity, volume and elongation can be changed (last 3 parameters). 

These factors define the characteristics of the objects that should be found. If you don’t 

want to adjust these parameters, use the default parameters. 

 



 

Figure 2: screen shot with the new pop-up window for parameter insertion of pixel size, sphericity, volume and elongation. 

If you know the pixel size of your stack, e.g., if you use the test_stack.tif continue with “Select area 

of interest”. 

If you don’t know the pixel size of your stack: 

 Pixelsize can be figured out by opening the sum.rec file in imod [3]. Then choose  

Edit > Model > Header thus a new window opens which contains the pixel size of the 

tomogram. 

 

Select area of interest: 

After some time another window will pop up, which requests you to select your area of interest: 

 Use one of the selection tools; (Figure 3, red box) here the freehand selection (Figure 3, red 

asterisk) was used. 



 

Figure 3: screen shot with highlighted Fiji selection tools (red box), that are used to draw a line around the inner cell membrane 

of the synapse (yellow line in tomogram) as area selection. Each selection has to be confirmed by pushing "T". Saved selections 

are listed in a new window (green box). 

 Make an area selection in the first slide of the stack. Here a line along the inner cell 

membrane of the middle cell in the tomogram was drawn with the freehand selection tool. 

(see Figure 3, yellow line in tomogram) 

 Confirm the selection by pressing the letter “T” at your keyboard (area selection is saved 

this way; see Figure 3, green box). 

 Make at least a second area selection in the last slide of the stack. 

(Area selections in the first and last picture of the stack are obligatory. Selections for the 

slides in between will be interpolated. Optionally, additional selections in between the first 

and last slide can be added for more accuracy.) 

 Confirm each selection by pressing the letter “T” at your keyboard. 

 After confirming by clicking “OK” in the pop-up window the macro starts. 

 

Please be patient now. The macro will need a couple of minutes depending on the performance 
of your computer. Don’t click at the appearing windows while the macro has not finished yet, 
because this may influence the flawless function of the macro. Don’t work simultaneously on 

something else at this computer. 



Results: 

As a result additional stacks are received: “Composit Stack”, “Stack Segmented” and  

“Stack Segmented Copy”. Furthermore the “RoiManager” as well as the “3D Viewer” open 

automatically. 

Explanation of the resulting stacks: 

 “Stack Segmented”: shows all the automatically recognized vesicles in different colours.  

 “Stack Segmented Copie”: an 8bit copy of the “Stack Segmented”, that is used for the three 

dimensional visualization of the recognized vesicles in the “3D Viewer”.  

 “Composit Stack”: is a combination of the original tomogram and the “Stack Segmented”, 

which can be used to verify the results of the automated annotation of the vesicles. 

 

Figure 4: Visual results of the macro (from left to right): original scaled tomogram, StackSegmented (registered vesicles in 

random colors) and Composit (combination of tomogram and "Stack Segmented") 

 For visualization of the reconstructed vesicle pool in 3D use Plugins > 3D Viewer and add 

the “StackSegmentedCopie”.  

 

Figure 5: View vesicle pool in 3D using the 3D Viewer Plugin 

 Select “display as” > Volume (figure 5, middle picture) or “display as” > Surface (figure 5, 



right picture) 

 Other parameters in the 3D Viewer window (figure 5, left picture) do not have to be 

changed 

 The 3D model can be turned and viewed from different angles by moving it with the left 

mouse button. 

Optional: manual editing by erasure of false positive particles 

When you look at the “Composit” stack or the 3D model you may find some particles that are false 

positives (e.g. microtubules, ER, or others). For the erasure of false positive particles there is an 

erase function in the “RoiManager” window.  

 

Figure 6: Erasure of false positive particles using the RoiManager. 

If you have spotted a false positive particle and you wish to erase it:  

1. Arrange all windows (“StackSegmented”, “Composit”,” RoiManager” and Fiji) as in Figure 6 

2. Put the slider of the “Composit” stack (Figure 6, yellow) to the right side (Figure 6, yellow 

arrow) 

3. Use your mouse cursor and move it on the particle that should be removed either in the 

“StackSegmented” or in the “Composit” (Figure 6, green arrows). 

4. If your mouse cursor is right above one particle, you can see its colour value in the Fiji 



window (Figure 6, green box, here: 243). 

5. Go to the RoiManager and search for this value in the object list (Figure 6, light red box) 

 If the RoiManager does not show the object list, select the “StackSegmented” and push 

the “Add Image” button in the right upper corner of the RoiManager 

6. Push the “LiveRoi” button (Figure 6, orange box), if you would like to mark the particle in 

one of the stacks. 

7. Push the “Erase” button (Figure 6, dark red box), if you wish to erase the particle. 

Important information concerning the erase function: 

 The particle will only be erased from the stack that was selected right before pushing 

“erase” as well as in the object list of the RoiManager. After application of the second 

macro (“3DART VeSElecT MeasureVesicle”), all stacks are updated and then will include the 

manual adjustments. 

 If you like to edit the results and erase all false positive particles, regard to erase all 

particles in the same stack (recommendation: in the “StackSegmented”). This will give you 

a better overview of the erased particles. 

 Tip: You can erase several particles simultaneously by selecting more than one particle in 

the object list of the RoiManager (therefore use “Shift” or “Ctrl”) 

Application of 3DART_VeSElecT_MeasureVesicle: 

 

After the successful application of the “3DART_VeSElecT_RegistVesicle.ijm” the 

“3DART_VeSElecT_MeasureVesicle.ijm” is being applied. Therefore all the windows which 

appeared as a result of the first macro are left open. Don’t save them if you intend to use the 

measurement macro, because of two reasons. First, the measurement macro will update the result 

stacks. Hence, manual adjustments will be included in all stacks. Second, saving the stacks in 

between will lead to a change of the stack’s name (e.g., “StackSegmented” to 

“StackSegmented.tif”). Therefore the measurement macro won’t recognize the stacks anymore. 



Start 3DART_VeSElecT_MeasureVesicle 

The second macro can be started in two ways: 

1. by choosing Plugins > Macros > Edit and selection of the macro file  

2. by selection of the window with the first macro, and: File > Open > selection of the 

measurement macro  

Either way, the macro will appear in the same window as the first macro.  

Start macro by pushing “RUN” at the left down corner of the window. 

As a result a new “Composit Stack”, “Stack Segmented” and “Stack Segmented Copy” will open, 

which include changes in case of manually erased particles. Furthermore a “Log” file is created 

which includes all measurement data from the investigated tomogram (the “Log” file may be 

somewhere in the background, hidden by the other windows). 

 

Optional:  

Use IMOD [3] for further modifications 

 

For manual addition of missing vesicles or further cellular components convert the automated 3D 

model and open it in IMOD: 

 save “StackSegmented” and “StackCopie” as .tif file in Fiji 

Figure 6: Characterization results in Log-file: includes a selection of the most important parameters that converted into 
nm scale. Parameters for each particle are: feret (biggest diameter), diameters in each direction (x, y, z), volume, the 
identity and distance of the closest 5 neighbours to each vesicle. 

 



 Conversion of both files using the command line (similar as described above on page 1): 

o convert “StackSegmented.tif” and “StackCopie.tif” to .mrc: 

→ tif2mrc -P name.tif name2.mrc 

 make model file: 

→ imodauto -h o “name2.mrc” “outputmodelfile.mod” 

 open IMOD 

 choose converted “StackCopie.mrc” as file 

 choose converted StackSegmented (“outputmodelfile.mod”) as model 

→ Functions and tools of IMOD are accessible now (e.g. with “V” the 3d model can be viewed) 

 

Potential error messages in Fiji and solutions: 

 “Out of memory”: This means the Fiji memory is not sufficient for this task. There are three 
solutions for this error: 

1. Fiji has accumulated data in the background, which requires some of the internal memory. 
 Solution: close Fiji completely, restart Fiji and try again 

2. Your input tomogram is too large. 
 Solution: CROP your tomogram, therefore use the rectangular selection tool in the 
toolbar, make a smaller selection in the tomogram and click: Image > Crop 

3. If you have large data, that can’t be cropped you can permit Fiji to use more memory space. 
 Solution: click Edit > Options > Memory&Threads and increase the memory 

 It is not recommended to increase the memory limit above ¾ of the physical memory! 

 “Unrecognized command: “3D Distance Map”:  
 Solution: close Fiji completely, restart Fiji and try again 

 
 

 



 
References 

[1] Schindelin J, Arganda-Carreras I, Frise E, Kaynig V, Longair M, Pietzsch T, Preibisch S, Rueden C, 

Saalfeld S, Schmid B, Tinevez JY, White DJ, Hartenstein V, Eliceiri K, Tomancak P, & Cardona A. Fiji: 

an open-source platform for biological-image analysis, Nature Methods (2012), 9(7): 676-682 

 

[2] Schneider CA, Rasband WS, Eliceiri KW. NIH Image to ImageJ: 25 years of image analysis. Nature 

Methods (2012), 9, 671-675. 

 

[3]Kremer JR, Mastronarde DN, McIntosh JR. Computer visualization of three-dimensional image 

data using IMOD. J Struct Biol. 1996;116(1):71-76. doi:10.1006/jsbi.1996.0013. 

 

[4]Ollion J, Cochennec J, Loll F, Escudé C, Boudier T. TANGO: a generic tool for high-throughput 3D 

image analysis for studying nuclear organization. Bioinformatics. 2013;29(14):1840-1841. 

doi:10.1093/bioinformatics/btt276. 

 

 

 


